One of the issues arising in testing is that some plugin code is failing on perl v5.24

May main development is on an older iMac and testing is in Ubuntu VMs, all of which seem to max out at v5.22. I downloaded Ubuntu server 17 and did a quick install under VMWare to get a system with perl 5.24 but squeezeserver 7.9.0 installation failed with an error something like squeezeboxserver depends on perl (>= 5.8.8); 

Thankfully, I found the solution here and I'm posting here for future reference as I'm sure it will come up again;

edit /etc/apt/sources.list
and add the line
deb http://http.us.debian.org/ squeeze main contrib

then proceed with

# apt-get install -f

Cron Job Starts